Most moka pots don't work on my induction stove. How can I still use them? I use a camping stove temporarily, but it requires me to buy gas refills every now and then. Is there an easier way?


Yes, you just need to get a pot that's made of the right stuff. Induction hobs only work with magnetic metals. If you can stick a magnet to your coffee pot, it will work. Traditional moka pots are made of aluminium, which is why they don't.

I have one that looks like this:

enter image description here

A quick search on Amazon should find you what you want, or enquire at your nearest big cookware store - the advisors there should be able to show you which ones will work (most will have indicators on the box in any case).

| improve this answer | |
  • 1
    Also you have to make sure the base is big enough. A small diameter pot may not work on some induction hobs. It just doesn't detect the pot, and won't switch on. eg the Bialetti Venus 2-cup is not recommended for induction hobs, but the 4 or 6 cup versions are. – vclaw Jan 28 '15 at 13:09

You can buy an induction adapter.

A quick search easily shows a few models.

Disclaimer: I have never tried one yet. Legacy gas around here.

| improve this answer | |
  • They would be quite a bit slower. As you have to wait for the plate to heat up, then for it to conduct heat to the pot. Plus would be less efficient, and use more electricity. So it loses the main advantages of an induction hob. – vclaw Feb 7 '15 at 17:42
  • 2
    I've been using an induction adapter with my moka pot. It works fine. Yes, it perhaps adds an extra minute or two (not really more than that in my case) depending on the thickness of the adapter (~1-2 mm thick in my case) and heat setting (~medium to medium high). – dearN Feb 19 '15 at 14:22

Shop for stainless pots with a magnet! If it sticks, they will work provided the base is big enough. I found a larger unbranded one (at Goodwill!) with a flared base that works perfectly with my portable induction cook plate. Start at 1500 watts and drop down to 300 as soon as the liquid begins to show up in the upper container, the drop even lower and finally off to avoid the final surge of overheated steam.

| improve this answer | |
  • Interesting! Welcome to Coffee SE. – Ivan Kapitonov Jan 2 '16 at 2:37

If you want to stick with your pot and don't want to use an adapter you could also buy a single stove like this one:

single stove

At least thats what my father uses. Its also nice because you can place it on the kitchen table so you don't have to get up once the coffee is ready. (Not to mention that this is a very handy device for keeping food/beverages warm and on the table).

| improve this answer | |

I had the same problem, and found a simple way to solve it: you might have a pot or pan that actually works on the hob, right? so, just put this one, empty, over the cooktop and then the moka pot inside this pot or pan. It has been working for me so far : )

| improve this answer | |

Please allow me to confirm the size thing: i use an alessi 3 cup on a portable induction hob, and have used on one permanent one - the base is about 3 inches - Works beautifully. Have just tried on another built-in induction hob (whirlpool schott ceran) and nothing. Take aways: - the magnet test is good to show potential to be an induction pot - the "induction" mark on the base of an item likewise (like this moka pot) - not all induction hobs, however, are created equal.

WHen looking through the manual on this hob that's NOT working with the pot, it does not say what the "minimum" size is for surface (eg, what is "too small"); all it says is if the thing is "not of the correct dimensions for your induction hob, the message "no pot" will appear in the display ".

Who knew one had to ask about "minimum dimensions" for a hob??

| improve this answer | |

PS - just found a hack for an induction hob that has failed to start up with one small indcution hob - as commented above:

Use two, as shown!

It's a fluke there are two of these available, but my guess is putting on anything induction-ish with the moka pot will work.

Satisfaction, of sorts. At least i can make coffee again :)

two moka pots work where on this induction hob one gets the "no pot" alert

| improve this answer | |

CNC Kitchen solved the issue by placing an iron disc inside the boiler.

This way he was able to make coffee even with a moka made of plastic.

| improve this answer | |

The magnet trick works, the bottom of the percolator says "induction", the hob is brand-new, but it doesn't work.

Would placing it in a pot work? Or would the pot explode and/or the bottom burn?

Desperate to have the smell of Italian coffee fill my apartment again...

| improve this answer | |
  • This seems like an independent question as opposed to an answer to the OP. – Mayo Jan 22 '19 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.