The pod drawer in my Lavazza coffee machine (model: LM600) is jammed.

I tried to pull it really hard, I tried to pry it open. I even gave a few strikes in hopes whatever is keeping it shut will shift inside. All for nothing.

I dismantled it partially, took a peek inside and retreated - with all the water tubing, that would be a major operation.

Any suggestions how to fix it?


Descaling was the answer!

  1. I mixed some vinegar with water in the tank (~1:1 ratio).
  2. I turned the dial to the dispensing positing, allowed some descaling solution to go through the machine.
  3. I turned the machine off and left it for a few minutes.
  4. I repeated steps 2 and 3 a few times.

At some point during the process, I heard a click inside - the lock that holds the drawer during brewing came unstuck and I was now able to pull the drawer out.

More information: Minù Caffè Latte manual with step-by-step descaling instructions

| improve this answer | |
  • 1
    I joined just to upvote this answer. Thank you so much! – KrisW Feb 13 at 10:02

I had the same problem and I have tried searching everywhere but I can't seem to find a good fix without unscrewing everything! Finally, someone posted this on youtube just recently and it worked! Hope this helps :) https://youtu.be/h8clAIgkjvI

| improve this answer | |
  • Welcome @Charlie. Normally, we describe the contents of a link, at least summarize, in case they may disappear in the future. – MTSan Sep 8 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.